Project

General

Profile

Bug #1158

iaDb::insert function doesn't work properly for mysqli

Added by Anonymous over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Start date:
November 13, 2013
Due date:
% Done:

100%

Estimated time:

Description

When mysqli is used sometimes insert method doesn't work properly.
Actually, it seems that the record is added, and the function returns id of the added item but as a result there is no such a record in the table.

For example, the issue appears in Shopping Cart plugin when adding category.

History

#1

Updated by Batyr Mackenov over 6 years ago

  • Status changed from New to Feedback

Could not reproduce.

#2

Updated by Batyr Mackenov over 6 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Fixed. the autocommit option was set to FALSE.

commit:729f39c

Also available in: Atom PDF