Project

General

Profile

Bug #154

Compatibility issues with php 5.2

Added by Vasily Bezruchkin over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Urgent
Category:
-
Target version:
Start date:
July 30, 2012
Due date:
% Done:

0%

Estimated time:

Description

The software works fine on PHP 5.3. There is one issue with getTable for the package class. Please check this example:

1. Real estate classified script, try the following code:

require_once IA_PACKAGES . 'realestate/includes/classes/ia.base.package.php';

class iaEstate extends abstractPackageAdmin implements iaRealEstatePackage, iaRealEstatePackageModule
{
    ...
    public function test()
    {
        echo self::getTable(true);
    }
    ...
}

It does not return the correct value for getTable method in PHP 5.2. Works fine in PHP 5.3

Please fix this.

History

#1

Updated by Vasily Bezruchkin over 7 years ago

  • Assignee set to Batyr Mackenov
  • Priority changed from High to Urgent
#2

Updated by Vasily Bezruchkin over 7 years ago

  • Status changed from New to Feedback
  • Target version changed from 2.2.2 to 2.2.3

This issue cannot be reproduced on local servers. Awaiting detailed instructions.

#3

Updated by Batyr Mackenov over 7 years ago

  • Status changed from Feedback to Closed

Unable to reproduce.
Closed.

Also available in: Atom PDF