Project

General

Profile

Bug #2411

Incorrect URL generation in Popular categories block

Added by Daiyrbek Artelov over 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
March 10, 2016
Due date:
% Done:

100%

Estimated time:

Description

Issue appear when Obtain visitor's location feature is turned on.
Here's the report from our customer:

Let us suppose we went to the following page: -

http://demos.subrion.com/yellowpages/location/Florida/Safety-Harbor/

Then we return to the home page. It now has "Safety Harbor" as the location.

Scroll down to the bottom of the page where you see the section "Popular categories". The problem is with the links inside this block.

For example, "Nightlife" goes to the correct page, but the link underneath it "Bars" gives the 404 error page.

It tries to send the user to: -

http://demos.subrion.com/yellowpages/Nightlife/Bars/

when it should send the user to

http://demos.subrion.com/yellowpages/Florida/Safety-Harbor/Nightlife/Bars/

History

#1

Updated by Daiyrbek Artelov over 3 years ago

  • Description updated (diff)
#2

Updated by Daiyrbek Artelov over 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Commit a7284c9f

#3

Updated by Vasily Bezruchkin almost 2 years ago

  • Target version changed from Backlog to 4.2.0

Also available in: Atom PDF