Project

General

Profile

Bug #88

Incorrect MySQL queries in admin panel

Added by Vasily Bezruchkin about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Immediate
Category:
-
Target version:
Start date:
July 04, 2012
Due date:
% Done:

100%

Estimated time:

Description

I'm confused with the following queries run in Admin Panel:

SELECT `block_id`, `id` FROM `sbr220_blocks_pages` WHERE `page_name` = 'database_manage';
SELECT * FROM `sbr220_blocks` WHERE `status` = 'active' AND `extras` IN ('', 'kcaptcha','yellowpages') ORDER BY `order`;
SELECT * FROM `sbr220_actions` WHERE `status` = 'blocks';
SELECT `id`, `alias`, `custom_url`, `name`, `parent`, `action` FROM `sbr220_pages` WHERE `status` = 'active' AND `extras` IN ('', 'kcaptcha','yellowpages');

Correct me if I'm wrong but it seems they are not used in Admin Panel so I suppose there no need to run them actually.

Please analyze MySQL queries and optimize the core system.

History

#1

Updated by Vasily Bezruchkin about 7 years ago

  • Target version changed from 2.2.1 to 2.2.2
#2

Updated by Vasily Bezruchkin about 7 years ago

  • Assignee changed from Anonymous to Batyr Mackenov
  • Priority changed from High to Immediate
#3

Updated by Batyr Mackenov about 7 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

The script was trying to load the blocks for backend as well since there was no respective check.

The issue is completely resolved.
Changes committed at rev #2612 (additional SQL optimizations also applied).

Also available in: Atom PDF